ERLANDSEN DATA CONSULTING Excel & VBA Tips   Information in English / Informasjon på engelsk

Disse websidene oppdateres ikke lengre og er kun tilgjengelig for historikken sin skyld.

Klikk her for å gå til den oppdaterte informasjonen.

Summer et regnearkområde i alle regnearkene

Det er mulig å få til dette ved hjelp av den vanlige SUMMER()-funksjonen, men dette kan bli en møysommelig og tidkrevende prosess dersom man har mange regneark i arbeidsboken eller man stadig legger til nye regneark. For å summere fra flere regneark kan man benytte SUMMER-funksjonen slik:

=SUMMER(Ark1:Ark10!A1:A100)

Formelen ovenfor summerer området A1:A100 i regnearkene Ark1 og Ark10, samt alle regneark som befinner seg mellom disse i arbeidsboken..

Ved hjelp av den egendefinerte funksjonen nedenfor kan man enkelt og greit summere et område i alle regnearkene i en arbeidsbok :

Function SumAllWorksheets(InputRange As Range, InclAWS As Boolean) As Double
' summerer innholdet i InputRange i alle regnearkene i arbeidsboken
Dim ws As Worksheet, TempSum As Double
    Application.Volatile True ' beregnes hver gang en celle oppdateres
    TempSum = 0
    For Each ws In ActiveWorkbook.Worksheets
        If InclAWS Then ' inkluder det aktive regnearket
            TempSum = TempSum + _
                Application.WorksheetFunction.Sum(ws.Range(InputRange.Address))
        Else ' ikke ta med det aktive regnearket
            If ws.Name <> ActiveSheet.Name Then ' ikke det aktive regnearket
                TempSum = TempSum + _
                    Application.WorksheetFunction.Sum(ws.Range(InputRange.Address))
            End If
        End If
    Next ws
    Set ws = Nothing
    SumAllWorksheets = TempSum
End Function

Funksjonen benyttes på samme måte som de innebygde regnearkfunksjonene. I Excel 5/95 må variabelen InputRange defineres som Variant i stedet for Range. Funksjonen kan enkelt endres til å omfatte andre regnearkfunksjoner som man ønsker å benytte på alle regnearkene i arbeidsboken.

 

Dokumentet er sist oppdatert 1999-08-14 12:41:47      Utskriftsvennlig versjon

 

Erlandsen Data Consulting     http://www.erlandsendata.no/   
Excel & VBA Tips   Copyright ©1999-2017    Ole P. Erlandsen   All rights reserved
E-post kontaktadresse