ERLANDSEN DATA CONSULTING Excel & VBA Tips   Information in English / Informasjon på engelsk

Disse websidene oppdateres ikke lengre og er kun tilgjengelig for historikken sin skyld.

Klikk her for å gå til den oppdaterte informasjonen.

Betinget summering

Ved hjelp av funksjonen SUMMERHVIS() kan du få Excel til å returnere summen av alle celler som tilfredsstiller et egendefinert kriterie.

Funksjonen =SUMMERHVIS(A1:A100;">1000") vil returnere summen av alle tall i området A1:A100 som er større enn 1000.

Funksjonen =SUMMERHVIS(A1:A100;">1000";B1:B100) vil returnere summen av alle tall i området B1:B100 som har en tilstøtende celle i området A1:A100 som er større enn 1000.

Funksjonen ANTALL.HVIS() kan benyttes på en tilsvarende måte dersom du ønsker å foreta en betinget telling.

 

Dokumentet er sist oppdatert 1999-08-14 12:41:47      Utskriftsvennlig versjon

Brukerkommentarer:
Ole P. fra Trondheim skrev (2006-02-01 08:38:46 CET):
Re: Betinget summering hvis en celle er fet
Endring av formatering på en eller flere celler trigger ikke en rekalkulering av formler i Excel.
En hendelesesmakro kan eventuelt benyttes til å foreta kalkuleringen for deg, dersom du finner en hendelse som forekommer ofte nok.
Ta en titt i menyen til venstre og velg "Hendelser" for mer informasjon om hendelsesmakroer.
Ole C fra Oslo skrev (2006-01-31 13:54:47 CET):
Betinget summering hvis en celle er fet
Hei

Jeg ønsker å telle alle cellene i en gitt rad der formatet på cella er fet(bold). Har laget en General function som ser slik ut:

Function isbold(inndata As Range) As Boolean

If inndata.Font.Bold = True Then
isbold = True
Else
isbold = False
End If
End Function

og i B-raden står alle cellene med formelen: =If(isbold(A1);1;0) hvor det er en sum(b1:b256) nederst i B-cella. Men hver gang jeg velger en celle i A-kolonne og gjør den fet eller ikke-fet, så vil formelen i cella ved siden av seg ikke oppdatere seg, jeg må fysisk inn i cella B og trykke Enter en gang for at cella skal oppdatere formelen. Er det noen som vet om det går å gjøre funksjonen og dermed formelen mere "dynamisk", dvs dersom man trykker på B-knappen for å gjøre en av A-cellene fet så endrer tallet ved siden av seg til 1 umiddelbart?
Ole P. fra Norway skrev (2004-11-26 18:14:06 CET):
Re: SUMMERHVIS kan bare bruke statiske kriterier?
Det går helt fint å benytte cellereferanser i kriteriet dersom dette er ønskelig, f.eks.:
=SUMMERHVIS($A$1:$A$100;B1) ' celle B1 inneholder f.eks. >100
=SUMMERHVIS($A$1:$A$100;">"&B1) ' celle B1 inneholder f.eks. 100
Kai A. Mortensen skrev (2004-11-26 09:04:46 CET):
SUMMERHVIS kan bare bruke statiske kriterier?
Kan SUMMERHVIS bare bruke statiske kriterier, eller kan det her brukes cellereferanser?

Finnes det andre funksjoner i Excel som kan gjøre denne jobben, men med dynamiske cellereferanser?

Gi meg gjerne en tilbakemelding på ePost (kai@tersen.cm)

 

Erlandsen Data Consulting     http://www.erlandsendata.no/   
Excel & VBA Tips   Copyright ©1999-2017    Ole P. Erlandsen   All rights reserved
E-post kontaktadresse