ERLANDSEN DATA CONSULTING Excel & VBA Tips   Information in English / Informasjon på engelsk

Disse websidene oppdateres ikke lengre og er kun tilgjengelig for historikken sin skyld.

Klikk her for å gå til den oppdaterte informasjonen.

Slå opp verdier i tabeller i eldre Excel-versjoner

Excel-versjoner før Excel 5.0 har ikke muligheten til å angi om den listen man slår opp i er sortert eller ikke. Dette medfører at man ikke får en feilmelding hvis søkeverdien ikke finnes i listen, samt at man alltid må ha sortert den listen man skal slå opp i. Funksjonen SAMMENLIGNE() kan benyttes sammen med funksjonen INDEKS() for å slå opp verdier i tabeller hvor det er nødvendig med eksakte oppslag.

SAMMENLIGNE(søkeverdi;søkematrise;type)

Denne funksjonen returnerer posisjonen til søkeverdien i en matrise som er angitt (enten nedover en kolonne eller bortover en rad). Bruk funksjonen i stedet for FINN.RAD() eller FINN.KOLONNE() når du har behov for posisjonen til søkeverdien i stedet for å returnere informasjon tilknyttet søkeverdien.

søkeverdi : det du ønsker å finne i tabellen, kan være tekst, tall eller en celle-referanse.
matrise : det celleområdet tabellen befinner seg i, eller det egendefinerte navnet brukeren har gitt celle-området.
type : fylles ut med -1, 0 eller 1 for å angi hvordan søkeverdien skal sammenlignes med verdiene i matrisen.
-1 : funksjonen returnerer posisjonen til den laveste verdien som er større enn eller lik søkeverdien. Verdiene i matrisen må sorteres synkende (omvendt alfabetisk).
0 : funksjonen returnerer posisjonen til den verdien som er identisk med søkeverdien. Verdiene i matrisen behøver ikke å sorteres. Funksjonen returnerer feilmeldingen #I/T hvis søkeverdien ikke finnes.
1 : funksjonen returnerer posisjonen til den høyeste verdien som er mindre enn eller lik søkeverdien. Verdiene i matrisen må sorteres stigende (alfabetisk).

Eksempel :
Anta at du har følgende tabell i et regneark :

Funksjon : Returnerer :
=INDEKS(A2:C6;SAMMENLIGNE(200;A2:A6;0);2) Appelsiner
=INDEKS(A2:C6;SAMMENLIGNE(400;A2:A6;0);3) 12
=INDEKS(A2:C6;SAMMENLIGNE(350;A2:A6;0);2) #I/T

 

Dokumentet er sist oppdatert 2000-02-05 12:42:38      Utskriftsvennlig versjon

 

Erlandsen Data Consulting     http://www.erlandsendata.no/   
Excel & VBA Tips   Copyright ©1999-2017    Ole P. Erlandsen   All rights reserved
E-post kontaktadresse