ERLANDSEN DATA CONSULTING Excel & VBA Tips   Information in English / Informasjon på engelsk

Disse websidene oppdateres ikke lengre og er kun tilgjengelig for historikken sin skyld.

Klikk her for å gå til den oppdaterte informasjonen.

Benytte logiske funksjoner

Mange benytter seg av den logiske funksjonen HVIS(logisk_test;hvis_sann;hvis_usann) for å få Excel til å ta logiske valg. Hvis du har mere kompliserte sammenligninger som skal utføres kan man benytte de logiske funksjonene OG(), ELLER() og IKKE() i tilknytning til HVIS()-funksjonen. Nedenfor følger en nærmere beskrivelse av funksjonen og eksempler på hvordan de brukes :

=HVIS(logisk_test;hvis_sann;hvis_usann)
: denne funksjonen kan utføre en logisk test. Du kan benytte følgende tegn og funksjoner for å beskrive den logiske testen :

Tegn : Logisk test :
= Lik
<> Ulik, kan ikke skrives som ><
> Større enn
>= Større enn eller lik
< Mindre enn
<= Mindre enn eller lik

 

Logisk funksjon : Returnerer :
OG() SANN hvis alle logiske tester er SANN
ELLER() SANN hvis en logisk test er SANN
IKKE() SANN hvis den logiske testen er USANN
ERF() SANN hvis celleverdien er en feilverdi ulik #I/T
ERFEIL() SANN hvis celleverdien er en feilverdi
ERIKKETEKST() SANN hvis celleverdien ikke er en tekst
ERIT() SANN hvis celleverdien er feilverdien #I/T
ERLOGISK() SANN hvis celleverdien er en logisk verdi
ERREF() SANN hvis celleverdien er en cellereferanse
ERTALL() SANN hvis celleverdien er et tall
ERTEKST() SANN hvis celleverdien er en tekst
ERTOM() SANN hvis celleverdien er tom (blanke celler)

=OG(logisk1;logisk2...) : denne funksjonen kan utføre inntil 30 logiske tester samtidig. Funksjonen returnerer verdien SANN hvis resultatet av alle de logiske testene returnerer verdien SANN, ellers returnerer funksjonen verdien USANN.

=ELLER(logisk1;logisk2...) : denne funksjonen kan utføre inntil 30 logiske tester samtidig. Funksjonen returnerer verdien SANN hvis resultatet av en eller flere av de logiske testene returnerer verdien SANN, ellers returnerer funksjonen verdien USANN.

=IKKE(logisk) : denne funksjonen benyttes for å reversere et logisk uttrykk til det motsatte. Argumentet logisk er en logisk test som returnerer verdien SANN eller USANN. Hvis argumentet logisk er SANN, vil funksjonen returnere verdien USANN. Funksjonen benyttes ofte til å gjøre det lettere å forstå den logiske testen.

Eksempel :

=HVIS(A1>=10;"Innholdet i A1 er større enn 10";"Ikke større enn
10")
=HVIS(ERTOM(A1);"Denne cellen må fylles ut !";"")
=HVIS(ERTEKST(A1);"Denne cellen må fylles ut med et tall!";"")
=HVIS(OG(A1>10;B1>20;C1>30);"Alle er større";"En eller flere er mindre")
=HVIS(ELLER(A1>10;B1>20;C1>30);"En eller flere er større";"Alle er mindre")
=HVIS(IKKE(A1>100);"Mindre enn 100";"Større enn 100")

 

Dokumentet er sist oppdatert 2000-02-04 12:42:50      Utskriftsvennlig versjon

 

Erlandsen Data Consulting     http://www.erlandsendata.no/   
Excel & VBA Tips   Copyright ©1999-2017    Ole P. Erlandsen   All rights reserved
E-post kontaktadresse